注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

爱生活,爱自己,爱思考

宜昌 提气儿喊

 
 
 

日志

 
 

大智慧自编选股条件  

2007-09-30 10:47:18|  分类: 股票基金投资 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

{选股一}

Var00:=LWINNER(1,CLOSE);
Var1:=FORCAST(Var00,10);
Var2:=MA(Var1,3);
Var3:=MA(Var2,12);
Var4:=MA(Var3,16);
Var5:=MA(Var4,31);
Var6:=MA(Var5,55);
Var7:=Var5; Var8:=Var4>Var2*1.11 AND Var3>Var2*1.095;
Var9:=Var2>Var1*0.95;
Var1h:=INDEXC;
Var2h:=MA(Var1h,6);
Var3h:=MA(Var1h,24);
Var4h:=MA(Var1h,32);
Var5h:=MA(Var1h,62);
Var6h:=MA(Var1h,105);
Var7h:=Var5h; Var8h:=Var4h>Var2h*1.11 AND Var3h>Var2h*1.095;
Var9h:=Var2h>Var1h*0.95;
pt:=(if(h=l and c=o and l=c and c>0 and ref(h,1)=ref(l,1) and ref(c,1)=ref(o,1)
and ref(h,1)=ref(c,1) and ref(c,1)>0,0,1))>0;
(Var7h AND Var8h AND Var9h AND CLOSE/COST(8)<=0.7985
and (count(c=l,4)<3 or c>ref(c,1)))and pt or
Var7 and Var8 and Var9 and CLOSE/COST(5)<=0.8 AND
((Var1>OPEN OR Var1>REF(OPEN,1) OR
REF(Var1,1)))

=================================================================================================

{自编选股二}

Var1:=INDEXC;
Var2:=MA(Var1,6);
Var3:=MA(Var1,24);
Var4:=MA(Var1,32);
Var5:=MA(Var1,62);
Var6:=MA(Var1,105);
Var7:=Var5<REF(Var5,1) AND Var6<REF(Var6,1) AND Var5<Var6*0.98;
Var8:=Var4>Var2*1.11 AND Var3>Var2*1.095;
Var9:=Var2>Var1*0.95;
Var7 AND Var8 AND Var9 AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));

================================================================================================

{自编选股三}

Var1:=99999999;
Var2:=1;
Var3:=Var2*(CLOSE-MA(CLOSE,42))/MA(CLOSE,42)*100;
HHV(CLOSE,20)/CLOSE>1.15 AND HIGH/LOW>1.05 AND CROSS(-28,Var3) ;

==================================================================================================

{自编选股四}

Var1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
Var2:=DMA(CLOSE,VOL/MA(VOL,33)/33);
Var3:=(CLOSE-Var1)/Var1*100<-11;
Var4:=(Var1-Var2)/Var2*100<-22.3;
Var5:=(WINNER(CLOSE*125/100)-WINNER(CLOSE))*100<8;
Var5 AND Var4;

=================================================================================================

{追涨选股

参数描述: N(1,22,15)N2(1,15,10)N3(-50,0,-30)N4(1,10,8)}
Var1:=1;
Var2:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100*Var1;
Var3:=(CLOSE-REF(OPEN, 29))/REF(OPEN, 29)*100*Var1;
Var4:=VOL/MA(VOL, 5)*Var1;
Var5:=WINNER(CLOSE)*100;
Var6:=VOL/CAPITAL*100*Var1;
Var7:=LLVBARS(LOW, 50)*Var1;
Var8:=SUM(VOL, Var7)*Var1;
Var9:=HHVBARS(HIGH, 50)*Var1;
Var10:=SUM(VOL, Var9)*Var1;
Var11:=(CLOSE-REF(OPEN, Var9))/REF(OPEN, Var9)*100*Var1;
Var12:=Var10/CAPITAL*100*Var1;
Var13:=(CLOSE-REF(OPEN, Var7))/REF(OPEN, Var7)*100*Var1;
Var14:=Var8/CAPITAL*100*Var1;
Var15:=(CLOSE-LLV(LOW, 45))/(HHV(HIGH, 45)-LLV(LOW, 45))*100;
Var16:=SMA(Var15, 3, 1);
Var17:=SMA(Var16, 3, 1);
Var18:=3*Var16-2*Var17;
Var19:=CLOSE<REF(CLOSE, 1);
Var20:=OPEN<REF(CLOSE, 1);
Var21:=Var17<N2 AND Var3<N3 AND Var2>N4;
Q:Var21 OR (COUNT(Var21, N) AND Var19 OR COUNT(Var21, N) AND Var20)*Var1;

=================================================================================================

{钻心选股}
Var1:=AMOUNT/VOL/100;
Var2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
Var3:=SUM(AMOUNT,13)/Var1/100;
Var4:=DMA(Var2,VOL/Var3);
Var5:=(CLOSE-Var4)/Var4*100;
Var6:=(INDEXC-LLV(INDEXL,9))/(HHV(INDEXH,9)-LLV(INDEXL,9))*100;
Var7:=SMA(Var6,3,1);
Var8:=SMA(Var7,3,1);
CROSS(Var7,Var8) AND Var7<45 AND COUNT(Var5<=-15,5)>=1

=================================================================================================

{条件选股    百发百中}
Var1:=INDEXC;
Var2:=MA(Var1,6);
Var3:=MA(Var1,24);
Var4:=MA(Var1,32);
Var5:=MA(Var1,62);
Var6:=MA(Var1,105);
Var7:=Var5<REF(Var5,1) AND Var6<REF(Var6,1) AND Var5<Var6*0.98;
Var8:=Var4>Var2*1.11 AND Var3>Var2*1.095;
Var9:=Var2>Var1*0.95;
VarA:=CLOSE/MA(CLOSE,48)*100<67;
VarB:=CLOSE/MA(CLOSE,50)*100<69;
VarC:=HIGH>LOW*1.078;
VarD:=VarC AND COUNT(VarC,4)>2;
VarD AND (VarA OR VarB)  OR Var7 AND Var8

=================================================================================================

{紧追感情}
Var1:=(CLOSE-LLV(CLOSE,21))/LLV(CLOSE,21)*1000;
Var2:=(CLOSE+OPEN)/2;
Var3:=(HIGH+LOW)/2;
Var4:=IF(CLOSE>REF(CLOSE,1),MAX(Var2,Var3),MIN(Var2,Var3));
Var5:=SUM(Var4*VOL,21)/SUM(VOL,21);
Var6:=VOL/CAPITAL*100;
VarA:=(CLOSE-Var5)/Var5*100<-16 AND CLOSE/HHV(CLOSE,50)<=0.8 AND CLOSE/LLV(CLOSE,5)<1.2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>-11 AND Var6<=10 AND COUNT(Var1>500,60)<1 AND FINANCE(7)<=80000;
VarA AND COUNT(VarA,5)>=1;

==================================================================================================

{黄金白银}
{参数:跌速(-50,0,-30),涨(-5.10,8),统计(1,20,20),备用(-5,10,3)}

Var2:=(CLOSE-REF(OPEN,19))/REF(OPEN,19)*100;
Var3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
Var4:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
Var5:=PWINNER(100,CLOSE)*100;{分析家此句:Var5:=LWINNER(100,CLOSE)*100;}
Var6:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
Var7:=SMA(Var6,3,1);
Var8:=SMA(Var7,3,1);
Var9:=3*Var7-2*Var8;
VarA:=COUNT(CROSS(Var7,Var8) AND Var8<8 AND Var3>涨 AND Var4<跌速,统计);
VarA OR VarA AND Var3<备用;

=================================================================================================

{智仁圆月,81~87%,信号多}
Var1:=DMA(CLOSE,VOL/SUM(VOL,34));
Var2:=(CLOSE-Var1)/Var1*100;
Var3:=(WINNER(CLOSE*1.2)-WINNER(CLOSE))*100<11;
Var4:=Var2<-19;
圆月:Var3 AND Var4

  评论这张
 
阅读(853)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017